Supplier Portal - Performance Issues

Incident Report for Tungsten Automation Americas

Resolved

This incident has been resolved.
Posted Dec 06, 2025 - 09:19 EST

Monitoring

A fix has been implemented, we are monitoring the results and expect full resolution shortly.
Posted Dec 06, 2025 - 06:47 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 06, 2025 - 05:04 EST

Investigating

We’re currently experiencing performance issues affecting access to the Supplier Portal for some customers. Our team is actively working to restore normal service as quickly as possible.

We appreciate your patience and will provide an update once everything is back to normal.
Posted Dec 06, 2025 - 03:46 EST
This incident affected: Supplier Portal.