Verification is currently underway for the maintenance items.
Posted Sep 04, 2025 - 14:28 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 04, 2025 - 05:05 EDT
Scheduled
Dear Printix User,
Printix 2025.3 will be deployed September 4, 2025.
What’s New in Printix 2025.3
Platform Enhancements
Windows Arm Processor Support: Now supports the latest Windows ARM devices, including new Microsoft Surface tablets with Snapdragon processors.
Capture SDK Enhancements: Added metadata support for improved workflow integration.
EU Data Act Compliance: Facilitate data export per Data Act requirements.
MFD Go Client Enhancements
Copy / Basic Accounting: Added for Brother and HP OXPD platforms
Metadata for Capture: Now supported on HP OXPD platform
Take Note
Mobile App Update Required: An updated Printix Mobile App is available on the Apple App and Google Play Stores. To support upcoming core service enhancements and ensure uninterrupted access, e nd users must update the Printix Mobile App.
PC and Mac Client Updates: Clients will not be automatically updated in this release and are on hold until March 2026. A new set of enterprise-friendly deployment options will arrive in early 2026, offering:
Phased deployments
Client version control
Option to opt out of automatic updates
Automated updates will remain available as a choice.
In the meantime, clients may still be updated manually or by the customers preferred deployment option.